3
$\begingroup$

I am running through a QE tutorial with silicon. The first half is using mostly pw.x and everything was working great. However when I started the part on band-structure I ran into this

$ /home/qe-7.1/bin/bands.x 
bash: /home/qe-7.1/bin/bands.x: No such file or directory

It is not a path problem since pw.x works fine with that path. I took a look at the bin directory and foundenter image description here which shows no bands.x. Where is it? I installed a while back and did the full install as far as I know. I think there are other missing .x files too.

Is there a way I can get the missing bands.x et al. without doing a complete do-over install? Any ideas why I don't have bands.x to begin with?

Using Ubuntu 20.04.

$\endgroup$
2
  • 2
    $\begingroup$ You can run make all from the /home/qe-7.1/ directory. It will take much less time than a complete installation since it will skip the already made executables and only the missing executables will be made. $\endgroup$ Jun 15, 2023 at 17:22
  • $\begingroup$ that worked perfectly! $\endgroup$
    – BeauGeste
    Jun 19, 2023 at 17:27

1 Answer 1

1
$\begingroup$

Try to locate bands.x if that doesn't work then do a reinstall with all of the perquisites

Install gcc and gfortran:

                  sudo apt install gcc

                  sudo apt install gfortran

Install required libraries

                  sudo apt install --no-install-recommends \

                  libopenmpi-dev \

                  libscalapack-openmpi-dev \

                  libelpa17


                  sudo apt install mpich

Also , Install

                sudo apt install --no-install-recommends \

                autoconf \

                build-essential \

                ca-certificates \

                libblas3 \

                libc6 \

                libfftw3-dev \

                libgcc-s1 \

                liblapack-dev \  wget

Get quantum espresso version of your choice and unpack

                wget https://gitlab.com/QEF/q-e/-/archive/qe-6.5/q-e-qe-6.5.tar.gz

                tar -xvzf q-e-qe-6.5.tar.gz

                cd qe-6.5


Configure and make

               ./configure --enable-parallel

               make pw

               make pp

               Or make all 
```
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .