1
$\begingroup$

I have been trying to compile and install NWChem v6.8 from a source code on Linux Mint 21.2. According to instructions received from chatGPT, the following steps have to be done:

  1. Install necessary packages
sudo apt install build-essential gfortran libopenblas-dev liblapack-dev libscalapack-openmpi-dev libfftw3-dev libblas-dev liblapack-dev libscalapack-openmpi-dev openmpi-bin
  1. Define environment variables
export NWCHEM_TOP=$PWD
export NWCHEM_TARGET=LINUX64
export NWCHEM_MODULES="all python"
export PYTHONHOME=/usr/bin/python3
export PYTHONVERSION=3.10.12
export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export MPI_LOC=/usr/lib/x86_64-linux-gnu/openmpi
export MPI_INCLUDE=$MPI_LOC/include
export MPI_LIB=$MPI_LOC/lib
export LIBMPI="-lmpi_usempi -lmpi_mpifh -lmpi"
export BLASOPT="-lopenblas -lpthread -lrt"
export LAPACK_LIB="-llapack -lopenblas -lpthread -lrt"
export SCALAPACK_LIB="-lscalapack -llapack -lopenblas -lpthread -lrt"
export USE_NOFSCHECK=TRUE
export CC=gcc
export FC=gfortran
  1. Then I changed the current directory from nwchem-6.8 into src being a child in relation to the first and ran the command make nwchem_config. As result, checking and configuring processed with ok-status until an error was thrown:
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether a simple C MPI program compiles... yes
configure: searching for MPI_TS...
checking mpi.h usability... yes
checking mpi.h presence... yes
checking for mpi.h... yes
checking for library containing MPI_Init... no
configure: error: test for COMEX_NETWORK=MPI_TS failed
configure: error: ../../ga-5.6.3/comex/configure failed for comex
make[1]: *** [GNUmakefile:657: build/config.status] Error 1
make[1]: exit directory "/home/me/_/soft/nwchem-6.8/src/tools"
make: *** [GNUmakefile:103: libraries] Error 1

(This is the several last strings of logging the process.)

Something being not right with the openmpi library can be supposed. I've checked it out with the following commands:

locate mpi.h
locate openmpi
mpirun --version
mpicc --version

It is all right. Then I've supposed that the comex library is not installed, but in the internet I've not watched something resembling.

Question: what things could be done to get it working?

$\endgroup$
4
  • 1
    $\begingroup$ Did you notice NWChem can be installed from Mint repositories? $\endgroup$
    – ksousa
    Aug 2, 2023 at 14:00
  • $\begingroup$ @ksousa Thanks to the comment! No, I didn't unfortunately. I have just been assuming that new versions will be released at first in source codes. So I'll watch and try, thanks. $\endgroup$
    – SFriendly
    Aug 3, 2023 at 3:02
  • $\begingroup$ Have you figured this out now? Please update us! Are you still urgently or actively in need of an answer? $\endgroup$ Dec 19, 2023 at 20:22
  • $\begingroup$ @NikeDattani Thank! Yes. It's not so urgently but I need an answer as before. $\endgroup$
    – SFriendly
    Dec 20, 2023 at 10:40

0

You must log in to answer this question.

Browse other questions tagged .