9
$\begingroup$

Today I tried to get an access to Molden to install it and use for processing the results of my calculations. Unfortunately the ftp seems to be down or is it only my personal connection issues?

My additional question is foreseeing: Does molden work on the latest macOS Catalina (v. 10.15)?

$\endgroup$
0
11
$\begingroup$

I believe that these instructions from this YouTube video "How to install Molden on Mac (OS X High Sierra)" work well

For some reason the "ftp" button on Molden's website is broken however, the curl command works easily

Here is a complete set of instructions from that video:

  1. Install Homebrew:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

  1. Install Cask: brew install cask
  2. Install XQuartz: brew cask install xquartz
  3. Install complier: brew install gcc
  4. Change working directory to desktop: cd desktop
  5. Download Molden source code: curl ftp://ftp.cmbi.ru.nl/pub/molgraph/molden/molden5.7.tar.gz -o molden5.7.tar.gz
  6. Unpack downloaded file manually or use command: tar -xzf molden5.7.tar.gz
  7. Change working directory to molden5.7: cd molden5.7
  8. Compile Molden: make all
  9. Remove original files (optional): rm -r */*.o */*.c */*.f */*.h */*.bak
  10. Start Molden: ./molden

  11. (Optional) cop molden executable to ~/bin and make sure ~/bin is in $PATH

Obviously skip installing Homebrew, Cask, XQuartz, gcc, if you don't need them!

$\endgroup$
3
  • 3
    $\begingroup$ Thank you, @CodyAldaz! This did work out and molden works on my OS, which is great! $\endgroup$ – Dmitry Eremin May 18 '20 at 7:32
  • $\begingroup$ I tried to follow the instructions of the video and from this question. On step 6, I got this message: curl: (28) Timeout was reached And the file is not downloaded. Could you help me? Thank you! $\endgroup$ – Nancy Elizabeth Dávila Guzmán Jul 18 '20 at 19:53
  • $\begingroup$ @NancyElizabethDávilaGuzmán Welcome to the site!!! We hope to see much more of you here!!! curl is a program for downloading things from the command line. What happened was probably an internet connection problem. Either your server was not allowing downloads, or the server that you were trying to download from, was not sending it to you, for whatever reason. You might want to ask your network administrator? $\endgroup$ – Nike Dattani Jul 18 '20 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.