18
$\begingroup$

I'm trying to set up iQmol as a tool to submit calculations to Q-Chem on our lab machines to make access to it easier for OChem students. Unfortunately, it is not working properly "from the box".

By default, when one creates a local server in iQmol it uses the csh shell environment and it looks like I only need to adjust Q-Chem environment:
local_server_settings

These settings nicely work for HF calculations, but when I try to use DFT I have a significant issue: SP or Optimization calculations go fine, but when Frequency calculation is added as a job, the calculation fails at the step "Calculating analytic Hessian of the SCF energy".

In the case of H2 molecule I stops like this:
Polarizability Matrix (a.u.)
1 2 3
1 0.0000000 0.0000000 0.0000000
2 0.0000000 0.0000000 0.0000000
3 0.0000000 0.0000000 -6.3752744
Calculating analytic Hessian of the SCF energy

It also gives an error message:
error_message
and the scratch folder for the job is not cleared after the job.

The input file is not the issue, as the same file can be submitted using the terminal and the calculation finishes successfully. It does not seem to be a memory issue, as specification of MEM_TOTAL and MEM_STATIC does not solve the problem. I thought that there might be a problem in server settings, but I can't figure out what exactly happened.

I will very much appreciate any suggestion and advice!

$\endgroup$
16
  • 2
    $\begingroup$ As someone who uses a Mac and Q-Chem (although admittedly not together) this seems strange. I'd contact Q-Chem tech support for help tracking this down. Is there an error message when the "Calculating analytic Hessian" step stops? $\endgroup$ – Geoff Hutchison May 18 '20 at 23:27
  • 1
    $\begingroup$ Q-Chem readdressed the question to iQmol, but they did not respond since November... I was hoping someone faced something similar, but succeeded. $\endgroup$ – Dmitry Eremin May 19 '20 at 0:05
  • 1
    $\begingroup$ Hi @DmitryEremin I just noticed that you are using -nt to do a Frequency calculation. Only use -np to do frequency calculations. If this works, I can make this an answer. $\endgroup$ – Cody Aldaz May 30 '20 at 4:36
  • 2
    $\begingroup$ Does it give an error message or just stop running? Can you increase the verbosity of the QChem output? $\endgroup$ – Tyberius Jul 11 '20 at 1:47
  • 2
    $\begingroup$ @Tyberius I tried for benzyl azide and couple of more. It is just exactly the same and always stops at the same moment. I also tried it on two different machines and tested several functionals and several basis sets. Interesting fact that it is with either bash shell or csh shell and under two different releases of macOS: High Sierra and Catalina. Makes me cry... $\endgroup$ – Dmitry Eremin Jul 16 '20 at 8:41
4
$\begingroup$

I do not think the server setup is the problem per se. By default, IQmol is setup to submit jobs to a server that is owned by Q-Chem and those jobs are time-limited at 5-10 min. (The precise limit has varied over time.) The job failed to finish error reflects this limit.

That said, I am a bit surprised that $\ce{H2}$ frequencies failed to finish. Is it possible that you are either:

  • (a) using a large basis set, or
  • (b) using a functional that lacks analytic 2nd derivatives, thus defaulting to finite-difference frequencies? I tried this just now and was successfully able to compute frequencies for $\ce{H2}$ at the B3LYP/6-31G level in a few seconds, well under the time limit.

In any case, the free IQmol server is intended primarily for demonstration purposes and for longer jobs you would need to purchase a Q-Chem license. IQmol can then be configured to submit jobs to local hardware.

$\endgroup$
1
  • $\begingroup$ Thank you for the comments! I agree the Q-Chem servers are the whole different story and they are limited to 10 minutes. However the problem I encounter is about server on a local machine. As Andrew Gilbert said "This shouldn’t be a problem, but IQmol was tripping up when it was looking for the pid." After playing for a while with .bashrc and environment settings I was able to run frequency calculations from iQmol for CO, H2O and CO2. However calculation still fails for larger systems even with very small basis set. Same calculations submitted to QChem from terminal works with no issues. $\endgroup$ – Dmitry Eremin Apr 21 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.