First of all, I already did electronic structure calculations in the past, but I am a total beginner regarding the use of Gaussian. Currently I am trying to use Gaussian16 through the terminal on linux and I keep getting an error message for basically all inputs I submit. The error that is raised right after the submission of the input is the following:

Error: segmentation violation
   rax 0000000000000000, rbx ffffffffffffffff, rcx 00002b30b4daf237
   rdx 000000000000c510, rsp 00007ffc7d2bf378, rbp 00007ffc7d2bf8f0
   rsi 000000000000000b, rdi 000000000000c510, r8  0000000000000020
   r9  00002b30b4eb0850, r10 000000007c998911, r11 0000000000000206
   r12 00007ffc7d2bf938, r13 0000000000000000, r14 0000000000000000
   r15 00000000000003e6
  /lib64/libpthread.so.0(+0x10c10) [0x2b30b486ac10]
  /lib64/libc.so.6(kill+0x7) [0x2b30b4daf237]
  /opt/g16/l301.exe() [0x627740]
  /opt/g16/l301.exe() [0x6462b1]
  /opt/g16/l301.exe() [0x6bfdb1]
  /opt/g16/l301.exe() [0x4073f7]
  /opt/g16/l301.exe() [0x4038e0]
  /opt/g16/l301.exe() [0x40381d]
  /lib64/libc.so.6(__libc_start_main+0xf5) [0x2b30b4d9a725]
  /opt/g16/l301.exe(sched_setaffinity+0xa1) [0x403729]

Here is an example of an input:

# HF/6-31G

methane energy

0 1
C   -0.000000   -0.000000   -0.000000 
H   0.633663    0.633663    0.633663
H   -0.633663   -0.633663    0.633663
H   0.633663   -0.633663   -0.633663
H   -0.633663    0.633663   -0.633663

I cannot tell if there is anything wrong with my input or if there is another problem. Any help is highly appreciated, because I did not find anything related elsewhere.

Edit: Calculations with small molecules are working now, but if I want to run calculations on molecules I need to do for my research I encounter the same error again. Here is the input of my molecule:

# HF/6-31G(d,p)

Organotellurium compound test

0 1
C      0.759205    2.343926   -0.396326
C      0.334605    0.988926    0.138474
C      0.661405   -0.183574   -0.755726
N      1.489405   -0.164274   -1.735426
O      1.653505   -1.303674   -2.379926
Te     0.622905   -2.856074   -1.619726
Cl    -1.167795   -2.437974   -3.173926
C     -0.019895   -1.450074   -0.505326
C     -1.125495   -1.514574    0.476374
C     -1.641995   -0.362774    0.957674
C     -1.179595    0.979926    0.397574
C     -1.566395    2.162426    1.259774
C     -0.951095    3.345526    1.063574
C      0.170305    3.455126    0.089374
H      1.555505    2.431126   -1.129126
H      0.813105    0.830526    1.131374
H     -1.501695   -2.473974    0.817174
H     -2.413795   -0.400874    1.720574
H     -1.652695    1.117826   -0.602426
H     -2.352895    2.075826    2.003474
H     -1.267095    4.221626    1.620574
H      0.514605    4.434526   -0.226426

I am starting to get really confused now. What am I doing wrong ? (Thanks in advance !)

  • $\begingroup$ If it is reproducible I would report it as a bug. A user should never be able to produce a segmentation violation. Of course, once in a while it happens in every code (and it is always a bug). $\endgroup$ Jul 29, 2022 at 16:07
  • 1
    $\begingroup$ @GregorMichalicek Gaussian traditionally responds to malformed input files by throwing a segfault...and in general one gets the feeling they use segfaults as a substitute for exceptions. $\endgroup$
    – TiborGY
    Jul 31, 2022 at 17:38
  • 1
    $\begingroup$ @TiborGY: I think, something like that should not just be accepted. Gaussian has a large user community and there are always new people who run into such issues. Who knows how much time and money from the users gets wasted because there is no adequate feedback from the program. I hope, the Gaussian developers at some point start to fix such program behavior and make the code more user friendly. But I guess, these thoughts are a little bit off topic here. $\endgroup$ Aug 1, 2022 at 7:14
  • $\begingroup$ This seems to be more suited for Stack Overflow.... $\endgroup$ Aug 2, 2022 at 9:54

1 Answer 1


The input looks otherwise correct but is missing the terminating blank line that is expected by Gaussian.

Add in the blank line at the end, and the input runs successfully.

Edit: as to the addendum of the question, the problem is that - exactly like Gaussian reports

Atomic number out of range for 6-31G basis set.

as the 6-31G** basis set is limited to light atoms.

My advice is to forget about obsolete Pople basis sets, and switch to modern basis set families that not only cover the whole periodic table but also come in systematic hierarchies of accuracy.

Changing the basis input from 6-31G(d,p) to def2SVP, which is a similar size basis from the Karslruhe family of Ahlrichs and coworkers but is available for the whole periodic table from H to Rn and efficiently includes relativistic effects through effective core potentials, the calculation runs.

PS. if you are doing research on such molecules, you definitely will want to use some other method than HF which yields poor chemistry.

  • $\begingroup$ I am now able to run calculations on small "test" molecules by putting in blank lines where they are required (thanks btw). But the same error (the segmentation violation above) is raised when I try to run calculations with the molecule I need to do research on. The input is shown in my edited question. Thanks in advance ! $\endgroup$
    – C_Swann22
    Jul 31, 2022 at 13:58
  • $\begingroup$ @C_Swann22 I amended the answer $\endgroup$ Jul 31, 2022 at 20:26
  • $\begingroup$ @C_Swann22 does this answer your question? $\endgroup$ Aug 3, 2022 at 15:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .