5
$\begingroup$

I am trying to load my MD trajectory to postprocess the velocities. Although I use the same exact script on the OPS website, I get the following error:

trajectory_from_mdtraj requires simtk.unit, which is not installed

I tried to pip install simtk which didn't solve the issue. Any suggestion would be greatly appreciated.

Thank you!

$\endgroup$
2
  • $\begingroup$ Did you tried with pip install simtk.unit? $\endgroup$
    – Camps
    Oct 8, 2022 at 21:32
  • $\begingroup$ Could you provide a link to the script you are using? The link in the post points to the main website. Also, do you have mdtraj installed? And I don't believe simtk can be installed with pip, because it needs another library in C++. $\endgroup$
    – S R Maiti
    Oct 9, 2022 at 19:55

1 Answer 1

3
$\begingroup$

The error message here is out of date -- simtk.unit was renamed to openmm.unit by the OpenMM maintainers. So this really means that you don't have OpenMM installed on your system. (Error message will be fixed in this pull request).

If you're not planning to use OpenMM for dynamics, then you probably want to load a trajectory using something like the solution in this answer.

If you are planning to use OpenMM for dynamics (as the examples do), then you'll definitely want to install OpenMM! You can do that with conda install -c conda-forge openmm. Note that OpenMM can not (yet) be installed with pip. You can see other optional installations that are supported by OPS in the docs on integration with other packages.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .